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OFFLINE CAPTURE

PRELIMINARIES

Know the Lab.

There are five (5) machines in the MoCap studio. The leftmost computer, “Waltz,” is the machine that you will use to do all of the Motion Capture and cleanup work. 

Next to Waltz is the Vicon capture machine, which must be networked to Waltz for anything to work.
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The white box here is the Vicon machine. it’s a good box, but can be a little tempermental. If it gives you any trouble, turn it off and on with the switch on the lower right.
Next to the Vicon machine is an SGI.

To the right of the SGI, on the other table, is a large black box, the MotionStar machine, which is used to process data from the magnetic tracking system in the lab.

To the right of the MotionStar box, past the A/V equipment, is a monitor that is used for both the realtime server, “Rumba” (the black Dell on the floor) and the realtime playback machine, “Muybridge.hcii”, which is running alice.
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Say hello to Russ if you see him down there. He gets lonely sometimes…
Know the Software.

On Waltz, you will find a desktop shortcut to a program called Workstation. This is the program that you will use to record motion and to build a skeleton from the MoCap data.

You will also find a shortcut to Bodybuilder. This tool will be used later to clean up the data that you’ve recorded.

To begin Capturing Motion, run Workstation.
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From the File Menu, Open the ETC MoCap Database:

File->Open Database->ETC
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This, of course assumes that you’re in the ETC. Otherwise, you may want to make a new database somehow.
That’s it for the preliminaries. Now you’re ready to get calibrated and get jiggy.

STEP I: Calibration

The first time you enter the MoCap Studio in WH1328, you will have to calibrate the Vicon Motion Capture System to ensure precise measurements. After initially calibrating the system, you should be able to use it without recalibration, provided the cameras are not moved in the studio.

Place the Static Calibration Axes on the floor as shown in the picture. In the center of the performance space, there is a large, blue, asterisk-shaped marking on the floor. Near this marking are two markings at right angles. Align the Axes approximately with these markings.
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This isn’t really a precise science. Just get the axes near the center of the capture space, which is delimited by blue markings on the floor.
The first order of business is to ensure that all of the cameras can see the axes.

Click on Camera Icon (the 5th button from the left) to bring up Live Monitor.
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Click the arrow buttons in the lower left to cycle through all of the cameras, making sure all 12 cameras can see axes..

If all is well, close the LiveMonitor. If all is not well, you may have to re-aim the cameras or clear all lines of sight to the axes. Reaiming the cameras is beyond the scope of this document. You should never have to do this, and should not attempt it without parental supervision.
Press the “Calibrate Button” – the 6th button from left on the toolbar
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The calibration process involves a static calibration and a dynamic calibration step. To begin calibration, press the “Calibrate” button.

Press start button to start the static calibration.

After approx. 3 seconds, the calibration should automatically stop. If it takes substantially longer (10 sec or more) or says “initializing”, you will have to hard boot the Vicon machine and restart the Workstation program to try again.

After the static calibration phase, remove the axes from the stage, and take out the calibration wand.
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This is the dynamic calibration wand (in the clear space capsule). It lives near all of the other markers behind the magic black curtain. Remember to close the curtain before capturing, as the reflections form the objects inside will screw up your data.
This, by the way, is the reason why we aren’t allowed to wear shoes in the lab. Aside from possibly damaging the special squishy floor, many shoes have highly reflective materials that reflect the IR light from the cameras.

Press start button again to begin the dynamic calibration step.

Walk around the stage area and wave wand around. Workstation will display a count of the number of frames taken. Go about 400 frames, or until you’ve covered entire space, and then press the stop button.
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Be sure to spend a good amount of the time waving the wand near the corners of the space. The lower bound is the floor, and the upper bound is a little higher than head level. You still have to do the other areas, but the corners require a little more attention.

The software will now display threshold and tolerance data. Make sure that the data displayed for each camera is less than 2mm. If this is not the case, repeat the calibration step, making sure to cover the entire stage with the wand (perhaps more slowly) during the dynamic calibration step.
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You should try to beat the record of 1.2mm error. That record was mine. Philo is not good at this at all. Russ has gotten an error measurement larger than the room, larger than CMU. It was a few kilometers…
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The next thing you have to do is to calibrate the sensitivity of the camera.  Having the camera too sensitive will have some of the marker balls show up more than once.  On the other hand, if the camera is not sensitive at all, it will miss some of the marker balls.  Go through each of the camera and adjust the sensitivity on the right, as pointed by the arrow in the picture.

The best way to calibrate the camera sensitivity is to have the subject that you are going to capture go to the four corners of the area that can be seen by the camera and adjust the camera sensitivity at each corner.
STEP II: SET UP SCENE OBJECTS

Now you will prepare the scene to capture. Click the 1st button to open project window.
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From the menu, select Trial-> Define Subjects, and press “New”.

Type in the name you wish to give to an object in your scene. For example, if there is a chair in your scene, you may wish to create a subject named “chair”.

Repeat this step for each object in your scene. 
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For each object in your scene:

1) Press the “Circle K” button to create a new “trial”

2) In the Trial Type dropdown, select “VR subject calibration”

3) Select the current object name from subjects list (e.g. “chair”)

4) Press “Types” button

5) Select an appropriate marker set to describe the current object. In the case of the chair, the marker set to use is called “C:\stage3\vanillaDemo\chair.mkr”

6) Press the capture button to get static data

7) Stop the calibration after a few seconds

8) Assign labels to all markers on object by clicking first on a marker (or sequence of markers) and then on the corresponding label (or series of labels)

To determine which marker is which, consult the appropriate .km file (chair.km)

9) From the menu, select Trial-> Create Autolabel Calibration and press OK

NOTE:

For human subjects, there are two positions that best calibrate the subject.  The first one is the T-position where the subject has his or her feet shoulder width apart and his or her arm raised up to his or her side with the thumb facing up and the palm facing forward.  The second position is the motorcycle position.  In this position, the subject assumes a position as though he or she is riding a bike.  The subject has his or her legs bent and both arms raised to the front.  The motorcycle position is used more often.  During subject calibration the subject must stay as still as possible. 

STEP III: RANGE OF MOTION CALIBRATION/CAPTURE

Press the “Circle-K” button to create a new trial, but this time, set the trial type to “VR Range Motion”.

If you intend to use the subject for online (real-time) motion capture later, press the “Pipeline” button. A list of checkboxes should appear. Check “Distance Statistics Collection Process,” and then press the “Options” button. In the dialog box, make sure that an appropriate .km file is specified. Also check “Realtime Subject Calibrator” and in its options dialog, specify the same .km file as you did for “Distance Statistics Collection Process.”
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For online or offline capture, start recording and move the object through its range of motion. For a human subject, s/he should move all joints through their entire range of motion – roll the neck, bent the elbows, circle the shoulders, etc.

Stop the capture.

The markers in the capture file should automatically label themselves according to the correlation established in the previous section. To verify that this is the case, make sure that the Mode in the lower right is set to “select” and pick the vertices. They should show labels on MouseOver.

If the markers are incorrectly labeled, you can reassign them as above. Note also that if a marker goes out of sight for a long period, the computer may be unable to accurately map the markers to their labels. In this case, you must manually specify the label/marker pairings.

STEP IV: Data Cleanup

IF YOU ARE DOING REAL-TIME MOCAP, DO NOT FILL ANY GAPS!!!

If you are doing off-line capture only, it will be necessary to clean the capture data to fill in any gaps. Much of this can be done by automatically filling gaps.

Open Bodybuilder (shortcut on desktop). This is the Vicon software used to clean up the data and also to analyze the data for biokinetic measurements. You will use it to do data cleanup on all of your captures.

When you first open the c3d file you are going to clean up, you’ll see the motion on top of a grid floor.  The motions that lie in the area of the grid floor is the best data so you might want to crop out the motions that lies outside the grid floor. You can do this by moving the timeline and closing and opening the file again.

From the menu, select Edit -> Fill All Gaps.  You can also specify the maximum gap that you want to fill by going to the menu and setting the Maximum Fill Gap.

This should take care of any small gaps that there may be in the data. Unfortunately, the larger gaps will require some personal attention.

Identify a gap in the data. You can watch the capture by pressing play in the lower left corner of the capture playback window. Any gaps in the data that were too large for the auto-cleaner should be obvious and easy to spot. Once you have spotted a gap in the data, select the offending marker, and double click to view graphs of its position in 3 dimensions. Find the gap in the data and click the ends of the lines. From the menu, click on both loose ends of the data surrounding the gap, and fill it from the menu. Click the “weighted dragging” button and manually adjust the curves to smoothly interpolate the data. This is as much an art as it is a science, but if you loot at other markers that are moving similarly, you should be able to come up with a reasonable approximation. For instance, if you are filling in gaps in the C7 marker at the top of the back, you may do well to model its motion after the motions of the clavicle and the sternum.

Now it’s time…

STEP V: Offline MoCap

You are now ready to capture and clean whatever animation data you want. The process is the same as in steps III and IV, with the exception that when creating the new trial, the Trial Type should be set to “General Capture”, rather than “VR Range Motion.”
There isn’t much to say about this. Start the trial, do your thing, and stop the trial. The Workstation software will then take its sweet time processing the data. Bring a Snickers bar.

You will surely have to do some data cleanup if your capture is long and complex, or even short and sweet. You’ll be there for a while, but it’s better than hand animating it, right?
STEP VI: Exporting Data to 3dStudioMax or Maya

To import the data to 3D Studio Max or Maya, you need to export the data to an ASF and AMC file.  The ASF and AMC files are common, and more or less standard, file formats for motion capture data.  The ASF file contains the skeleton information of the subject.  The AMC file contains all the motions of the subject; to reconstruct the motion, you will need the appropriate ASF file.

The steps here will only show you how to export the .c3d file of the vicon system into an ASF and AMC file.  To import it into 3D Studio Max or Maya, you will need the necessary plugins and they have their own steps.

To create the ASF file: 

1) Open Bodybuilder

2) Open the c3d file for the subject calibration (either the T-position or motorbike position for human subjects)

3) In Model(Subject Settings, set .mp file.  A list of different .mp files can be found in C:\Vicon\Model.  Copy the one that you want to use and put it in your directory.

4) Select Model(Create ASF file

To create the AMC file:

1) Open Bodybuilder

2) Open the c3d file you want to use

3) Select Model(create AMC file

NOTE:

You can create your own .mod and .mp files if you need a different kind of skeleton.  Check the Bodybuilder manual for more information.

ONLINE (REALTIME) CAPTURE
If you’ve gotten this far, you should have no problem capturing animation data and playing it back in realtime.

For a realtime capture, do everything that you would for an offline capture, up to and including step III. You must also register these objects as capable of real-time capture by selecting RealTime->Add Subjects from the menu and adding them to the list.

Then, on the Realtime Server (Rumba.graphics), run the Tarsus Server program, Tarsus.exe, which is located in the Tarsus folder on the desktop. You could actually run this program on any machine. If you run it on Waltz instead of Rumba (for example), expect it to take up about  66% of your processor time (this means no video capture). 

Connect Workstation on Waltz to Tarsus (on Rumba or another machine) by pressing the “connect to realtime server” button in Workstation (13th button on bar – looks like pipe w/ arrow) or selecting Realtime->Connect from the menu.

Check the Tarsus server on Rumba to make sure there are no errors, and press the “activate” button in Workstation (Waltz, to the right of the “connect” button). Data should now be flowing through the real-time server. 
Read the Tarsus protocol documentation for an overview of how the data is sent to your real-time applications.

If you don’t care to write your own application, start up Alice on Muybridge.hcii  (the rightmost computer) and load up an Alice world containing models corresponding to the objects you are motion capturing. In the Behaviors, you need a ViconBehavior, and the script must contain code to map the real-time data to the objects. See Stage3’s sample world for further information about mapping bodies to objects in Alice. To see the output of the world on the HMD/projector, be sure to press <ALT>+<ENTER> on the Muybridge.hcii keyboard (and, of course, make sure the HMD/projector is on).

About the <Wireless> HMD

The “wireless” HMD lives on the table near Muybridge, in the corner of the lab.
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The HMD is powered by a battery pack, carried in the blue backpack. When charging, the battery pack will be off. MAKE SURE TO TURN IT OFF WHEN YOU RECHARGE IT!
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Even Rebecca knows where the power switch is.

The HMD gets its video signal from an X10 video receiver, also carried in the backpack (yeah, it’s kind of heavy). This receiver gets signals from a transmitter in the ceiling above the (0,0,0) point of the room (the place you put the axes for static calibration). This transmitter can broadcast on either channel 3 or channel 4. It doesn’t matter which it is, but make sure that the X10 receiver in the backpack is on the same channel.
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You may have to stand on a chair to see what channel the transmitter is broadcasting on.
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Becca points at the transmitter. The receiver is in her left hand. They’re both on channel 4.

Oh, and one more thing… as of the writing of this manual, the HMD is a Sony Glasstron from Japan, and its buttons are labeled in Japanese. FYI: the Japanese word equivalent of “power” is “入り” – making the power button the slider with the arrow next to it. Below this, you will find a “スタート” (English: “start”) button, that you will have to press several times when you first power up the device in order to get a picture.
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That’s about it for the Zoom Guide to MoCap. If you have any other questions…
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Oh, and when you’re done…
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